Advisory ID: LUCKVM-SA-2026-1031-LXD
Published: October 31, 2026
Severity: Critical — CVSS v4.0 10.0 (CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H)
Identifiers: CVE-2026-112816 (GHSA-99jp-jwmc-65p4 / GHSA-pq55-m3w3-jh54, CWE-295)
Affected Products: Canonical LXD (4.0, 5.0, 5.21, and 6 tracks) and Canonical MicroCloud (2 and 3)
1. Executive Summary
Canonical has disclosed a maximum-severity (CVSS v4.0 10.0) authentication bypass vulnerability tracked as CVE-2026-112816 affecting the HTTPS listener in Canonical LXD and MicroCloud.
Due to improper certificate chain validation (CWE-295), an unauthenticated remote attacker who reaches the LXD HTTPS API and possesses a trusted client's public certificate (without needing any password or private key) can authenticate as that trusted client via a crafted certificate chain. Successful exploitation grants full administrative control over the LXD cluster, all managed system containers and virtual machines, and can lead to root compromise on the underlying host.
Platform Reassurance: LuckVM's underlying KVM cloud infrastructure, Dedicated Servers, and Bulk-IP Proxmox VE / VMware Bare-Metal Hosts are not affected. Workloads using standard Docker or native Proxmox VE LXC containers are also unaffected. However, customers who have deployed LXD (with the remote HTTPS listener enabled) or MicroCloud on their LuckVM instances or bare-metal servers must take immediate action.
2. Technical Root Cause (CWE-295: Improper Certificate Validation)
-
How the mTLS Bypass Works: Remote clients authenticate to the LXD HTTPS API using mutual TLS (mTLS) by presenting a client certificate chain. Cryptographically, only the first certificate in the chain (the leaf certificate) proves that the connecting client holds the matching private key. However, affected versions of LXD compared every certificate in the client-supplied chain against the local trust store. Consequently, an attacker can generate a self-signed leaf certificate, append a trusted client's public certificate further down the chain, and be accepted by LXD as that trusted administrator.
-
MicroCloud Cluster Exposure: In MicroCloud deployments, an attacker can intercept the public certificate of a member node joining a cluster and use it to authenticate as that cluster member.
-
Prerequisite for Network Exploitation: By default, LXD listens only on a local Unix socket. Hosts are vulnerable to remote network exploitation whenever the HTTPS listener is enabled (
core.https_addressis configured) or when operating in a LXD/MicroCloud cluster.
3. Affected & Patched Versions
Ironically, CVE-2026-112816 specifically impacts the point releases (4.0.14, 5.0.10, 5.21.8, and 6.9.0–6.10.0) that many administrators recently installed to address earlier host-root vulnerabilities (CVE-2026-87799, CVE-2026-85185, CVE-2026-85526):
| Release Track | Vulnerable Version Range | Patched Release | Snap Channel Status Note (as of Oct 31) |
| LXD 6 (LTS) | >= 6.9.0 and |
|
|
| LXD 5.21 (LTS) | >= 5.21.8 and |
|
Verify build after refresh (channel lag reported) |
| LXD 5.0 (LTS) | >= 5.0.10 and |
|
Verify build after refresh (channel lag reported) |
| LXD 4.0 (LTS) | >= 4.0.14 and |
|
Verify build after refresh (channel lag reported) |
| MicroCloud | Affected 2.x and 3.x builds |
Latest Snap revision |
Refresh |
(Note: The community fork Incus, which originally referred this flaw to Canonical, is tracked separately under GHSA-xg75-xf37-cph9—ensure Incus installations are also updated.)
4. Remediation & Hardening Instructions
Step 1: Refresh the LXD and MicroCloud Snaps (Do Not Rely on apt)
Canonical distributes LXD exclusively as a Snap package on supported Ubuntu releases; running apt upgrade will not patch your LXD installation. Take a precautionary Snapshot in the LuckVM Dashboard, then run:
sudo snap refresh lxd
sudo snap refresh microcloud
Step 2: Verify the Installed Version (Critical Channel Lag Warning)
Independent checks on October 31, 2026 revealed that while 6/stable serves the patched 6.10.1 build, the 5.21, 5.0, and 4.0 stable channels in the Snap Store may still serve vulnerable builds, or a configured snap refresh --hold (which can delay updates for up to 90 days) may prevent the upgrade. Always verify your active version immediately after refreshing:
snap list lxd
Confirm that the installed version matches 6.10.1, 5.21.9, 5.0.11, or 4.0.15.
Step 3: Audit & Restrict the LXD HTTPS API Listener
Check whether your LXD daemon is exposing the HTTPS API to the network:
lxc config get core.https_address
-
If you do not require remote API access (Single-Host Setup): Disable the network listener immediately so LXD binds strictly to the local Unix socket:
Bashlxc config unset core.https_address -
If you operate a LXD/MicroCloud Cluster or require remote API access: Especially if your release track (
5.21,5.0, or4.0) has not yet received the patched build on the stable channel, immediately restrict access to the LXD HTTPS port (typically TCP8443) using firewall rules (ufw,iptables, ornftables) so that only trusted cluster peer IPs and internal management bastion hosts can connect. Never exposecore.https_address(8443) to0.0.0.0/0on the public internet.
Step 4: Audit the LXD Trust Store
Review all client certificates currently trusted by your LXD daemon or cluster:
lxc config trust list
Remove any stale, unrecognized, or overly broad client certificates, and inspect your system and LXD access logs for anomalous authentication events.
If you need assistance configuring firewall rules, taking instance snapshots, or migrating containerized workloads onto dedicated LuckVM Bulk-IP Proxmox VE / VMware Bare-Metal Hosts, please contact our 24/7 engineering team via the LuckVM Support Portal.
LuckVM Infrastructure & Security Team
![[Security Advisory] Out-of-Band Critical JSSE Vulnerability in Oracle Java SE, GraalVM & OpenJDK (CVE-2026-91403, CVSS 9.1): Fix Guide](https://www.luckvm.com/upload/common/default/b86745c7d3326f2e3c4d19d34984fc95b5cf02df36064e54%5EImage_l3cwyxl3cwyxl3cw.png)
![[Security Advisory Update] Official Patches Released for Critical PHP "PHP2Shell" RCE Vulnerabilities (CVE-2026-109618 & CVE-2026-109619, CVSS 9.2)](https://www.luckvm.com/upload/common/default/68ff644d1f13eb6b98dd03e7b60ab787dd58d1c2ac1813ae%5Ee2ab34c6-19c1-4a00-b4c0-2188a91bf55c.png)
![[Security Advisory] Critical PHP Core RCE Vulnerabilities (CVE-2026-109618 & CVE-2026-109619 / "php2shell", CVSS 9.2) — Impact & Remediation Plan](https://www.luckvm.com/upload/common/default/e1b9b141ed19329fb466078df66762ac62541b57b5d33595%5Eb09788b6-f5eb-4a79-b063-805aa9cd0b82.png)